您現在的位置:程序化交易>> 股票公式>> 其他>> 其他軟件公式>>正文內容

封神榜已全面優化完成,分A,B兩板(公式、源碼)[其他軟件公式]

相關標簽:

?

封神榜已全面優化完成,分A,B兩板A板
參數: (N 1 120 10) ( M 1 60 3)
VAR1:=("399139$C");
VAR2:=("399190$C");
VAR3:=("399132$C");
VAR4:=("399150$C");
VAR5:=("399138$C");
VAR6:=("399200$C");
VAR7:=("399110$C");
VAR8:=("399136$C");
VAR9:=("399135$C");
VAR10:=("399130$C");
VAR11:=("399160$C");
VAR12:=("999999$C");
VAR13:=("399137$C");
醫藥:=SUM((VAR1/REF(VAR1,1)-1)*100,0);
金融:=SUM((VAR2/REF(VAR2,1)-1)*100,0);
紡織:=SUM((VAR3/REF(VAR3,1)-1)*100,0);
建筑:=SUM((VAR4/REF(VAR4,1)-1)*100,0);
機械:=SUM((VAR5/REF(VAR5,1)-1)*100,0);
地產:=SUM((VAR6/REF(VAR6,1)-1)*100,0);
農林:=SUM((VAR7/REF(VAR7,1)-1)*100,0);
電子:=SUM((VAR8/REF(VAR8,1)-1)*100,0);
石化:=SUM((VAR9/REF(VAR9,1)-1)*100,0);
制造:=SUM((VAR10/REF(VAR10,1)-1)*100,0);
運輸:=SUM((VAR11/REF(VAR11,1)-1)*100,0);
上證:SUM((VAR12/REF(VAR12,1)-1)*100,0),COLORRED;
金屬:=SUM((VAR13/REF(VAR13,1)-1)*100,0);
VAR17:=CONST(MA(醫藥,N));
VAR18:=CONST(MA(金融,N));
VAR19:=CONST(MA(紡織,N));
VAR20:=CONST(MA(建筑,N));
VAR21:=CONST(MA(機械,N));
VAR22:=CONST(MA(地產,N));
VAR23:=CONST(MA(農林,N));
VAR24:=CONST(MA(電子,N));
VAR25:=CONST(MA(石化,N));
VAR26:=CONST(MA(制造,N));
VAR27:=CONST(MA(運輸,N));
VAR28:=CONST(MA(上證,N));
VAR29:=CONST(MA(金屬,N));
PQ:=VAR29-20;
P1:=IF(BARSLAST(CURRBARSCOUNT=4),1,0);
P2:=IF(BARSLAST(CURRBARSCOUNT=6),1,0);
P3:=IF(BARSLAST(CURRBARSCOUNT=8),1,0);
P4:=IF(BARSLAST(CURRBARSCOUNT=10),1,0);
P5:=IF(BARSLAST(CURRBARSCOUNT=12),1,0);
P6:=IF(BARSLAST(CURRBARSCOUNT=14),1,0);
P7:=IF(BARSLAST(CURRBARSCOUNT=16),1,0);
P8:=IF(BARSLAST(CURRBARSCOUNT=18),1,0);
P9:=IF(BARSLAST(CURRBARSCOUNT=20),1,0);
P10:=IF(BARSLAST(CURRBARSCOUNT=22),1,0);
P11:=IF(BARSLAST(CURRBARSCOUNT=24),1,0);
P12:=IF(BARSLAST(CURRBARSCOUNT=26),1,0);
P13:=IF(BARSLAST(CURRBARSCOUNT=28),1,0);
P14:=IF(BARSLAST(CURRBARSCOUNT=2),1,0);
STICKLINE(醫藥,PQ,IF(P2-P1,CONST(MA(醫藥,M)),DRAWNULL),5,0),COLORYELLOW;
STICKLINE(金融,PQ,IF(P3-P2,CONST(MA(金融,M)),DRAWNULL),5,0),COLORYELLOW;
STICKLINE(紡織,PQ,IF(P4-P3,CONST(MA(紡織,M)),DRAWNULL),5,0),COLORYELLOW;
STICKLINE(建筑,PQ,IF(P5-P4,CONST(MA(建筑,M)),DRAWNULL),5,0),COLORYELLOW;
STICKLINE(機械,PQ,IF(P6-P5,CONST(MA(機械,M)),DRAWNULL),5,0),COLORYELLOW;
STICKLINE(地產,PQ,IF(P7-P6,CONST(MA(地產,M)),DRAWNULL),5,0),COLORYELLOW;
STICKLINE(農林,PQ,IF(P8-P7,CONST(MA(農林,M)),DRAWNULL),5,0),COLORYELLOW;
STICKLINE(電子,PQ,IF(P9-P8,CONST(MA(電子,M)),DRAWNULL),5,0),COLORYELLOW;
STICKLINE(石化,PQ,IF(P10-P9,CONST(MA(石化,M)),DRAWNULL),5,0),COLORYELLOW;
STICKLINE(制造,PQ,IF(P11-P10,CONST(MA(制造,M)),DRAWNULL),5,0),COLORYELLOW;
STICKLINE(運輸,PQ,IF(P12-P11,CONST(MA(運輸,M)),DRAWNULL),5,0),COLORYELLOW;
STICKLINE(金屬,PQ,IF(P13-P12,CONST(MA(金屬,M)),DRAWNULL),5,0),COLORYELLOW;
STICKLINE(上證,上證,IF(P1-P14,VAR28,DRAWNULL),5,-1),COLORYELLOW;
STICKLINE(醫藥,PQ,IF(P2-P1,VAR17,DRAWNULL),4,0),COLORRED;
STICKLINE(金融,PQ,IF(P3-P2,VAR18,DRAWNULL),4,0),COLORRED;
STICKLINE(紡織,PQ,IF(P4-P3,VAR19,DRAWNULL),4,0),COLORRED;
STICKLINE(建筑,PQ,IF(P5-P4,VAR20,DRAWNULL),4,0),COLORRED;
STICKLINE(機械,PQ,IF(P6-P5,VAR21,DRAWNULL),4,0),COLORRED;
STICKLINE(地產,PQ,IF(P7-P6,VAR22,DRAWNULL),4,0),COLORRED;
STICKLINE(農林,PQ,IF(P8-P7,VAR23,DRAWNULL),4,0),COLORRED;
STICKLINE(電子,PQ,IF(P9-P8,VAR24,DRAWNULL),4,0),COLORRED;
STICKLINE(石化,PQ,IF(P10-P9,VAR25,DRAWNULL),4,0),COLORRED;
STICKLINE(制造,PQ,IF(P11-P10,VAR26,DRAWNULL),4,0),COLORRED;
STICKLINE(運輸,PQ,IF(P12-P11,VAR27,DRAWNULL),4,0),COLORRED;
STICKLINE(金屬,PQ,IF(P13-P12,VAR29,DRAWNULL),4,0),COLORRED;
STICKLINE(醫藥,PQ,IF(P2-P1,CONST(醫藥),DRAWNULL),0.8,0),COLORAAAAFF;
STICKLINE(金融,PQ,IF(P3-P2,CONST(金融),DRAWNULL),0.8,0),COLORAAAAFF;
STICKLINE(紡織,PQ,IF(P4-P3,CONST(紡織),DRAWNULL),0.8,0),COLORAAAAFF;
STICKLINE(建筑,PQ,IF(P5-P4,CONST(建筑),DRAWNULL),0.8,0),COLORAAAAFF;
STICKLINE(機械,PQ,IF(P6-P5,CONST(機械),DRAWNULL),0.8,0),COLORAAAAFF;
STICKLINE(地產,PQ,IF(P7-P6,CONST(地產),DRAWNULL),0.8,0),COLORAAAAFF;
STICKLINE(農林,PQ,IF(P8-P7,CONST(農林),DRAWNULL),0.8,0),COLORAAAAFF;
STICKLINE(電子,PQ,IF(P9-P8,CONST(電子),DRAWNULL),0.8,0),COLORAAAAFF;
STICKLINE(石化,PQ,IF(P10-P9,CONST(石化),DRAWNULL),0.8,0),COLORAAAAFF;
STICKLINE(制造,PQ,IF(P11-P10,CONST(制造),DRAWNULL),0.8,0),COLORAAAAFF;
STICKLINE(運輸,PQ,IF(P12-P11,CONST(運輸),DRAWNULL),0.8,0),COLORAAAAFF;
STICKLINE(金屬,PQ,IF(P13-P12,CONST(金屬),DRAWNULL),0.8,0),COLORAAAAFF;
DRAWTEXT(P2-P1,PQ-2,'醫藥'),COLORYELLOW;
DRAWTEXT(P3-P2,PQ-2,'金融'),COLORYELLOW;
DRAWTEXT(P4-P3,PQ-2,'紡織'),COLORYELLOW;
DRAWTEXT(P5-P4,PQ-2,'建筑'),COLORYELLOW;
DRAWTEXT(P6-P5,PQ-2,'機械'),COLORYELLOW;
DRAWTEXT(P7-P6,PQ-2,'地產'),COLORYELLOW;
DRAWTEXT(P8-P7,PQ-2,'農林'),COLORYELLOW;
DRAWTEXT(P9-P8,PQ-2,'電子'),COLORYELLOW;
DRAWTEXT(P10-P9,PQ-2,'石化'),COLORYELLOW;
DRAWTEXT(P11-P10,PQ-2,'制造'),COLORYELLOW;
DRAWTEXT(P12-P11,PQ-2,'運輸'),COLORYELLOW;
DRAWTEXT(P13-P12,PQ-2,'金屬'),COLORYELLOW;
B板
VAR1:=("399120$C");
VAR2:=("399170$C");
VAR3:=("399333$C");
VAR4:=("399220$C");
VAR5:=("399180$C");
VAR6:=("399134$C");
VAR7:=("399210$C");
VAR8:=("399133$C");
VAR9:=("399140$C");
VAR10:=("399131$C");
VAR11:=("399001$C");
采掘:=SUM((VAR1/REF(VAR1,1)-1)*100,0);
IE業:=SUM((VAR2/REF(VAR2,1)-1)*100,0);
中小板:=SUM((VAR3/REF(VAR3,1)-1)*100,0);
傳播:=SUM((VAR4/REF(VAR4,1)-1)*100,0);
批零:=SUM((VAR5/REF(VAR5,1)-1)*100,0);
造紙:=SUM((VAR6/REF(VAR6,1)-1)*100,0);
服務:=SUM((VAR7/REF(VAR7,1)-1)*100,0);
木材:=SUM((VAR8/REF(VAR8,1)-1)*100,0);
水電:=SUM((VAR9/REF(VAR9,1)-1)*100,0);
食品:=SUM((VAR10/REF(VAR10,1)-1)*100,0);
深證:SUM((VAR11/REF(VAR11,1)-1)*100,0),COLORRED;
VAR13:=CONST(MA(采掘,N));
VAR14:=CONST(MA(IE業,N));
VAR15:=CONST(MA(中小板,N));
VAR16:=CONST(MA(傳播,N));
VAR17:=CONST(MA(批零,N));
VAR18:=CONST(MA(造紙,N));
VAR19:=CONST(MA(服務,N));
VAR20:=CONST(MA(木材,N));
VAR21:=CONST(MA(水電,N));
VAR22:=CONST(MA(食品,N));
VAR23:=CONST(MA(深證,N));
PQ:=VAR22-20;
P1:=IF(BARSLAST(CURRBARSCOUNT=4),1,0);
P2:=IF(BARSLAST(CURRBARSCOUNT=6),1,0);
P3:=IF(BARSLAST(CURRBARSCOUNT=8),1,0);
P4:=IF(BARSLAST(CURRBARSCOUNT=10),1,0);
P5:=IF(BARSLAST(CURRBARSCOUNT=12),1,0);
P6:=IF(BARSLAST(CURRBARSCOUNT=14),1,0);
P7:=IF(BARSLAST(CURRBARSCOUNT=16),1,0);
P8:=IF(BARSLAST(CURRBARSCOUNT=18),1,0);
P9:=IF(BARSLAST(CURRBARSCOUNT=20),1,0);
P10:=IF(BARSLAST(CURRBARSCOUNT=22),1,0);
P11:=IF(BARSLAST(CURRBARSCOUNT=24),1,0);
P12:=IF(BARSLAST(CURRBARSCOUNT=2),1,0);
STICKLINE(采掘,PQ,IF(P2-P1,CONST(MA(采掘,M)),DRAWNULL),5,0)COLORYELLOW;
STICKLINE(IE業,PQ,IF(P3-P2,CONST(MA(IE業,M)),DRAWNULL),5,0),COLORYELLOW;
STICKLINE(中小板,PQ,IF(P4-P3,CONST(MA(中小板,M)),DRAWNULL),5,0),COLORYELLOW;
STICKLINE(傳播,PQ,IF(P5-P4,CONST(MA(傳播,M)),DRAWNULL),5,0),COLORYELLOW;
STICKLINE(批零,PQ,IF(P6-P5,CONST(MA(批零,M)),DRAWNULL),5,0),COLORYELLOW;
STICKLINE(造紙,PQ,IF(P7-P6,CONST(MA(造紙,M)),DRAWNULL),5,0),COLORYELLOW;
STICKLINE(服務,PQ,IF(P8-P7,CONST(MA(服務,M)),DRAWNULL),5,0),COLORYELLOW;
STICKLINE(木材,PQ,IF(P9-P8,CONST(MA(木材,M)),DRAWNULL),5,0),COLORYELLOW;
STICKLINE(水電,PQ,IF(P10-P9,CONST(MA(水電,M)),DRAWNULL),5,0),COLORYELLOW;
STICKLINE(食品,PQ,IF(P11-P10,CONST(MA(食品,M)),DRAWNULL),5,0),COLORYELLOW;
STICKLINE(深證,深證,IF(P1-P12,VAR23,DRAWNULL),5,-1),COLORYELLOW;
STICKLINE(采掘,PQ,IF(P2-P1,VAR13,DRAWNULL),4,0),COLORRED;
STICKLINE(IE業,PQ,IF(P3-P2,VAR14,DRAWNULL),4,0),COLORRED;
STICKLINE(中小板,PQ,IF(P4-P3,VAR15,DRAWNULL),4,0),COLORRED;
STICKLINE(傳播,PQ,IF(P5-P4,VAR16,DRAWNULL),4,0),COLORRED;
STICKLINE(批零,PQ,IF(P6-P5,VAR17,DRAWNULL),4,0),COLORRED;
STICKLINE(造紙,PQ,IF(P7-P6,VAR18,DRAWNULL),4,0),COLORRED;
STICKLINE(服務,PQ,IF(P8-P7,VAR19,DRAWNULL),4,0),COLORRED;
STICKLINE(木材,PQ,IF(P9-P8,VAR20,DRAWNULL),4,0),COLORRED;
STICKLINE(水電,PQ,IF(P10-P9,VAR21,DRAWNULL),4,0),COLORRED;
STICKLINE(食品,PQ,IF(P11-P10,VAR22,DRAWNULL),4,0),COLORRED;
STICKLINE(采掘,PQ,IF(P2-P1,CONST(采掘),DRAWNULL),0.8,0),COLORAAAAFF;
STICKLINE(IE業,PQ,IF(P3-P2,CONST(IE業),DRAWNULL),0.8,0),COLORAAAAFF;
STICKLINE(中小板,PQ,IF(P4-P3,CONST(中小板),DRAWNULL),0.8,0),COLORAAAAFF;
STICKLINE(傳播,PQ,IF(P5-P4,CONST(傳播),DRAWNULL),0.8,0),COLORAAAAFF;
STICKLINE(批零,PQ,IF(P6-P5,CONST(批零),DRAWNULL),0.8,0),COLORAAAAFF;
STICKLINE(造紙,PQ,IF(P7-P6,CONST(造紙),DRAWNULL),0.8,0),COLORAAAAFF;
STICKLINE(服務,PQ,IF(P8-P7,CONST(服務),DRAWNULL),0.8,0),COLORAAAAFF;
STICKLINE(木材,PQ,IF(P9-P8,CONST(木材),DRAWNULL),0.8,0),COLORAAAAFF;
STICKLINE(水電,PQ,IF(P10-P9,CONST(水電),DRAWNULL),0.8,0),COLORAAAAFF;
STICKLINE(食品,PQ,IF(P11-P10,CONST(食品),DRAWNULL),0.8,0),COLORAAAAFF;
DRAWTEXT(P2-P1,PQ-2,'采掘'),COLORYELLOW;
DRAWTEXT(P3-P2,PQ-2,'IE業'),COLORYELLOW;
DRAWTEXT(P4-P3,PQ-2,'中小板'),COLORYELLOW;
DRAWTEXT(P5-P4,PQ-2,'傳播'),COLORYELLOW;
DRAWTEXT(P6-P5,PQ-2,'批零'),COLORYELLOW;
DRAWTEXT(P7-P6,PQ-2,'造紙'),COLORYELLOW;
DRAWTEXT(P8-P7,PQ-2,'服務'),COLORYELLOW;
DRAWTEXT(P9-P8,PQ-2,'木材'),COLORYELLOW;
DRAWTEXT(P10-P9,PQ-2,'水電'),COLORYELLOW;
DRAWTEXT(P11-P10,PQ-2,'食品'),COLORYELLOW;

{程序化交易 www.qvudci.tw }

{程序化交易 www.qvudci.tw }

{程序化交易 www.qvudci.tw }

?

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

?

 

有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

怎么收費,代編流程等詳情請點擊查閱!

(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  浙江体彩6+1规则