您現在的位置:程序化交易>> 股票公式>> 其他>> 其他軟件公式>>正文內容

橫盤上漲 分時指標公式,預警指標公式[其他軟件公式]

相關標簽:

?

?

?

原理解析:


?

?來源:程序化99( www.qvudci.tw )

源碼:

?

?

?

tt:=BARSCOUNT(C);
CC:=CLOSE;
zz:=SUM(AMOUNT,tt)/SUM(VOL*100,tt);
zz1:=BETWEEN(C/zz,1.05,0.95);
均線:=IF(zz1=0,MA(C,TT),zz);
上均:=均線 + AVEDEV(C,tt)*2;
下均:=均線 - AVEDEV(C,tt)*2;
時長:=if(HOUR>=13 AND HOUR<15 ,1,0);
漲幅:=(close/DYNAINFO(3))>=1.03;
跌幅:=(close/DYNAINFO(3))<=0.97;
漲跌幅:=漲幅 OR 跌幅;
yy:=SMA(vol,30,1);
放量:=(yy-LLV(Llv(yy,1),30))/(HHV(Hhv(yy,1),30)-LLV(Llv(yy,1),30))>0;
橫盤:=((HHV(CLOSE,TT)-LLV(CLOSE,TT))/CLOSE)<=0.05;
橫盤上漲:=漲跌幅=0 and 橫盤 and 時長 and 放量and CROSS(CC,上均)and DYNAINFO(22)<DYNAINFO(23);
上突:FILTER(橫盤上漲,100);{程序化交易 www.qvudci.tw }


做成選股指標的源碼是:
{上突選股}
N:=20;
tt:=BARSCOUNT(C);
CC:=CLOSE;
zz:=SUM(AMOUNT,tt)/SUM(VOL*100,tt);
zz1:=BETWEEN(C/zz,1.05,0.95);
均線:=IF(zz1=0,MA(C,TT),zz);
上均:=均線 + AVEDEV(C,tt)*2;
時長:=if(HOUR>=13 AND HOUR<15 ,1,0);
漲幅:=(close/DYNAINFO(3))>=1.03;
跌幅:=(close/DYNAINFO(3))<=0.97;
漲跌幅:=漲幅 OR 跌幅;
yy:=SMA(vol,30,1);
放量:=(yy-LLV(Llv(yy,1),30))/(HHV(Hhv(yy,1),30)-LLV(Llv(yy,1),30))>0;
橫盤:=((HHV(CLOSE,TT)-LLV(CLOSE,TT))/CLOSE)<=0.05;
橫漲:=漲跌幅=0 and 橫盤 and 時長 and 放量and CROSS(CC,上均)and DYNAINFO(22)<DYNAINFO(23) ;
PP:= FILTER(橫漲,100) ;
DRAWTEXT(PP,上均,'上突'),colorff00ff;
上突:PP,LINETHICK0;

公式也附上了
注意:如果用來選股,周期使用1分鐘,在周期是1分鐘的k線圖中,如果最后一個周期有信號,預警(選股)就會有信號。

?

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

?

 

有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

怎么收費,代編流程等詳情請點擊查閱!

(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  浙江体彩6+1规则