您現在的位置:程序化交易>> 股票公式>> 其他>> 其他軟件公式>>正文內容

SS研判區間買賣[其他軟件公式]

相關標簽:

?

SS研判區間買賣.alg
名稱: SS研判區間買賣類別:技術指標
說明:
公式組: 教學專用

?

?

原理解析:


?

?來源:程序化99( www.qvudci.tw )

源碼:

?

?


STICKLINE(CLOSE>=OPEN,LOW,HIGH,0.5,0),colorFF;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,8,0),color102088;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,7,0),color102099;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,6,0),color1020AA;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,5,0),color1020BB;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,4,0),color1020CC;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,3,0),color1020DD;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,2,0),color1020EE;
STICKLINE(CLOSE>=OPEN,CLOSE,OPEN,1,0),color1020FF;
STICKLINE(CLOSE<=OPEN,LOW,HIGH,0.5,0),colorFF8800;
STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,8,0),colorFF7700;
STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,7,0),colorFF8800;
STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,6,0),colorFF9900;
STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,5,0),colorFFAA00;
STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,4,0),colorFFBB00;
STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,3,0),colorFFCC00;
STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,2,0),colorFFDD00;
STICKLINE(CLOSE<=OPEN,CLOSE,OPEN,1,0),colorFFEE00;
A3:=CLOSE=HHV(CLOSE,6);
A9:=CLOSE=LLV(CLOSE,6);
A4:=BARSLAST(A3);
A5:=BARSLAST(A9);
A6:=IF(A4,REF(CLOSE,A4),REF(CLOSE,A4))*1.005;
A7:=IF(A5,REF(CLOSE,A5),REF(CLOSE,A5))*0.995;
PARTLINE(A6=REF(A6,1),A6),LINEDOT,colorFF00;
PARTLINE(A7=REF(A7,1),A7),LINEDOT,colorFFFF;
A11:=MA(LOW,2);
A12:=IF(A11>REF(A11,1),A11,REF(A11,BARSLAST(A11>REF(A11,1))));
PARTLINE(CLOSE<A12,A12),LINETHICK2,colorFFFFFF;
AA:=(3*CLOSE+HIGH+LOW+OPEN)/6;
AA1:=WMA(AA,2);
AAC1:=WMA(AA,3);
AAC2:=WMA(AA,5);
ABC:=WMA(AA,8);
ABD:=WMA(AA,13);
ABBC:=WMA(AA,18);
BBC2:=REF(ABBC,1);
做多C:IF(AAC1>=BBC2,AAC1,BBC2),LINETHICK1,colorEE00EE;
做多C1:IF(AAC2>=BBC2,AAC2,BBC2),LINETHICK1,colorFFFFFF;
做多C2:IF(ABC>=BBC2,ABC,BBC2),LINEDOT,LINETHICK1,colorFFFF;
做多D2:IF(ABD>=BBC2,ABD,BBC2),LINEDOT,LINETHICK1,colorFF00;
做多C3:IF(ABBC>=BBC2,ABBC,BBC2),LINEDOT,LINETHICK1,colorFF;
做空C2:IF(BBC2-ABBC,BBC2,ABBC),LINETHICK2,colorFF00;
PARTLINE(BBC2>REF(BBC2,1),BBC2),LINETHICK2,colorFF00FF;
PARTLINE(AAC1<REF(AAC1,1) AND AAC1>ABBC,AAC1),LINETHICK3,colorFF0000;
PARTLINE(AAC2<REF(AAC2,1) AND AAC2>ABBC,AAC2),LINETHICK2,colorFF00;
PARTLINE(ABC<REF(ABC,1) AND ABC>ABBC,ABC),LINETHICK3,color5B00;
PARTLINE(ABD<REF(ABD,1) AND ABD>ABBC,ABD),LINETHICK2,color16BBCD;
DDA:=IF(SYSPARAM(1)=(BARSSINCE(CLOSE>0))+1,1,0);
DRAWTEXT(DDA>0,SYSPARAM(4),'【迷惑創于09.05.01】'+'\n'+'3日加權移動平均('+NUMTOSTR(AAC1[SYSPARAM(1)],2)+')\n'+'5日加權移動平均('+NUMTOSTR(AAC2[SYSPARAM(1)],2)+')\n'+'8日加權移動平均('+NUMTOSTR(ABC[SYSPARAM(1)],2)+')\n'),ALIGN2,PXUP127,colorFFFF00;
ZX:=AA1-BBC2;
DRAWTEXTEX(SYSPARAM(3)=BARPOS,0,5,5,'【迷惑創于09.05.01】'),LINETHICK1,colorFFFFFF;
STICKLINE(ZX>=0,AA1-ZX*0.05,AA1-ZX*0.15,2,0),colorFFFF;
STICKLINE(ZX>=0,AA1-ZX*0.2,AA1-ZX*0.35,2,0),colorCCFF;
STICKLINE(ZX>=0,AA1-ZX*0.4,AA1-ZX*0.55,2,0),color99FF;
STICKLINE(ZX>=0,AA1-ZX*0.6,AA1-ZX*0.75,2,0),color66FF;
STICKLINE(ZX>=0,AA1-ZX*0.8,AA1-ZX*0.95,2,0),colorCC;
STICKLINE(ZX<0,BBC2+ZX*0.05,BBC2+ZX*0.15,2,0),color6600;
STICKLINE(ZX<0,BBC2+ZX*0.2,BBC2+ZX*0.35,2,0),color9900;
STICKLINE(ZX<0,BBC2+ZX*0.4,BBC2+ZX*0.55,2,0),colorCC00;
STICKLINE(ZX<0,BBC2+ZX*0.6,BBC2+ZX*0.75,2,0),colorFF00;
STICKLINE(ZX<0,BBC2+ZX*0.8,BBC2+ZX*0.95,2,0),color66FF00;

?

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

?

 

有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

怎么收費,代編流程等詳情請點擊查閱!

(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  浙江体彩6+1规则