您現在的位置:程序化交易>> 股票公式>> 通達信>> 通達信公式>>正文內容

CD抄底之四指標公式(副圖指標公式、公式、源碼、演示圖)[通達信公式]

相關標簽:

?

?

?

原理解析:


?

?來源:程序化99( www.qvudci.tw )

源碼:

?

?

?

VAR2:=(HIGH+LOW+(CLOSE)*(2))/(4);
BH:=((EMA((VAR2-LLV(VAR2,15))/(HHV(LOW,15)-LLV(VAR2,15)),2))*(38)),COLOR0000FF,LINESTICK;
BL:=((((-1))*(EMA((VAR2-LLV(VAR2,15))/(HHV(LOW,15)-LLV(VAR2,15)),2))+0.01)*(38)),COLOR339999,LINESTICK;
VAR22:=((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10)))*(100);
VAR33:=EMA(VAR22,10);
VAR44:=EMA(VAR33,10);
VAR55:=(3)*(VAR33)-(2)*(VAR44);
VAR66:=EMA(VAR55,5);
姑娘:(EMA(VAR66,1)),COLOR007700,LINETHICK1;
男人:(REVERSE(姑娘)),COLORFFFFFF,LINETHICK1;
{(0),COLORFFFF00,LINETHICK3;}
趨勢:=(5)*(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1))-(3)*(SMA(SMA(((CLOSE-LLV(LOW,27))
/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1))-SMA(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1),2,1);
底部:=5;
{底:DRAWTEXT((CROSS(趨勢,底部)),0,'◥◤'),COLOR00FFFF;}
DRAWTEXT(CROSS((趨勢),底部),15,'◢◣'),COLOR00FFFF;
{DRAWTEXT(CROSS(趨勢,底部),0,''),COLORRED;
DRAWTEXT(CROSS(趨勢,底部),20,'●'),COLORGREEN;}
VARA1:=((CLOSE>=REF(CLOSE,1)) AND (REF(CLOSE,1)>=REF(CLOSE,2)) AND (REF(CLOSE,1)<=REF(CLOSE,3))
AND (REF(CLOSE,2)<=REF(CLOSE,3)) AND ((REF(CLOSE,4)>REF(CLOSE,2)) OR (REF(CLOSE,4)<=REF(CLOSE,2))
AND (REF(CLOSE,5)>=REF(CLOSE,3))) OR (CLOSE>=REF(CLOSE,1)) AND (REF(CLOSE,1)<=REF(CLOSE,2))
AND (CLOSE>=REF(CLOSE,2)) AND ((REF(CLOSE,3)>REF(CLOSE,1)) OR (REF(CLOSE,3)<=REF(CLOSE,1)) AND (REF(CLOSE,4)>=REF(CLOSE,2))));
VARA2:=LLV(LOW,5);
VARA3:=HHV(HIGH,5);
VARA4:=EMA(((CLOSE-VARA2)/(VARA3-VARA2))*(100),1);
VARA5:=EMA((0.66699999)*(REF(VARA4,1))+(0.333)*(VARA4),2);
VARA6:=(VARA5<24) AND (OPEN<MA(CLOSE,20));
VARA1 AND (VARA6),COLORFF0000;
STICKLINE(VARA1 AND (VARA6),-40,40,10,1),COLOR2894FF;
VARB2:=((CLOSE-LLV(LOW,10))/(HHV(HIGH,10)-LLV(LOW,10)))*(100);
VARB3:=EMA(VARB2,7);
VARB4:=EMA(VARB3,10);
VARB5:=(3)*(VARB3)-(2)*(VARB4);
VARB6:=EMA(VARB5,5);
趨勢1:=(3)*(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1))-(2)
*(SMA(SMA(((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27)))*(100),5,1),3,1));
探底:IF((趨勢<=5),58,0),COLORFF00FF;
橋1:=EMA(VARB6,1);
美化:=IF(REF((COUNT((橋1<=REF(橋1,1)),5)=5),1) AND (橋1>REF(橋1,1)),10,0);
STICKLINE((美化),-20,20,15,1),COLORFFFF00;
MTM1:MA((CLOSE-REF(CLOSE,13))*31,5),LINETHICK1,COLOR7711EE;
VARF1:=MA(HHV(HIGH,485),17);
VARF2:=MA(HHV(HIGH,222),17);
VARF3:=MA(HHV(HIGH,96),17);
VARF4:=MA(LLV(LOW,485),17);
VARF5:=MA(LLV(LOW,222),17);
VARF6:=MA(LLV(LOW,96),17);
VARF7:=MA((VARF4*0.96+VARF5*0.96+VARF6*0.96+VARF1*0.558+VARF2*0.558+VARF3*0.558)/6,17);
VARF8:=MA((VARF4*1.25+VARF5*1.23+VARF6*1.2+VARF1*0.55+VARF2*0.55+VARF3*0.65)/6,17);
VARF9:=MA((VARF4*1.3+VARF5*1.3+VARF6*1.3+VARF1*0.68+VARF2*0.68+VARF3*0.68)/6,17);
VARFA:=MA((VARF7*3+VARF8*2+VARF9)/6*1.738,17);
VARFB:=IF(C=C,VARFA,VARFA*DAY);
VARFC:=LOW;
VARFD:=REF(LOW,1);
VARFE:=SMA(ABS(VARFC-VARFD),3,1)/SMA(MAX(VARFC-VARFD,0),3,1)*100;
VARFF:=MA(IF(CLOSE*1.35<=VARFB,VARFE*10,VARFE/10),3);
VARF10:=LLV(LOW,30);
VARF11:=HHV(VARFF,30);
絕佳買點:IF(C=C,MA(IF(LOW<=VARF10,(VARFF+VARF11*2)/2,0),3),100000000)/(200),COLORRED,LINETHICK2;
I:=IF(CLOSE<REF(CLOSE,1),0,VOL/CAPITAL);
驟雨初晴:=ABS(EMA(I,13.3)-18)/WINNER(CLOSE)*IF((CLOSE-MA(CLOSE,6))/MA(CLOSE,6)<-0.04,1,0);
W:=COST(10)*0;
DIFF:=EMA(CLOSE,12) - EMA(CLOSE,26),COLORRED;
DEA:=EMA(DIFF,9),COLORYELLOW;
MACD:=2*(DIFF-DEA)*231,STICK,COLORRED,LINETHICK1;
STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0.9,0),COLOR00FFFF;
STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0.8,0 ),COLORFFEE44;
STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,1.1,0 ),COLOR0055FF;
STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,1.1,0 ),COLORFF55BB;
DRAWTEXT(CROSS(絕佳買點,1.20000) ,-32,'金屋'),COLORYELLOW,LINETHICK2 ;
DRAWTEXT(CROSS(絕佳買點,4.50000) ,63,'藏嬌'),COLOR00FFFF,LINETHICK2;
{DRAWTEXT(CROSS(絕佳買點,7.00000) ,88,'金屋3'),COLORCYAN,LINETHICK4;}
DRAWTEXT(CROSS(絕佳買點,3.60000) ,28,'金屋2'),COLORFF00FF,LINETHICK4;
{DRAWTEXT(CROSS(絕佳買點,2.40000) ,-55,'金屋1'),COLORFFFFCC,LINETHICK3 ; };

?

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

?

 

有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

怎么收費,代編流程等詳情請點擊查閱!

(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  浙江体彩6+1规则