您現在的位置:程序化交易>> 股票公式>> 大智慧>> 大智慧公式>>正文內容

分時疊加大盤[標準]+大盤5分鐘力度和總體力度[大智慧公式]

相關標簽:

?

分時疊加大盤[標準]+大盤5分鐘力度和總體力度


1.先建大盤引用指標

?

原理解析:


?

?來源:程序化99( www.qvudci.tw )

源碼:

?

?

?



{大盤引用}
昨收:REF(C,1),LINETHICK0;
BS:=COUNT(V>0,0);
KB1:=BS=1 AND DYNAINFO(3)<DYNAINFO(4);
KS1:=BS=1 AND DYNAINFO(3)>DYNAINFO(4);
KB2:=BARSLAST((C>REF(C,1) OR BS=1))+KS1;
KS2:=BARSLAST((C<REF(C,1) OR BS=1))+KB1;
BV:=IF(KB2<KS2,AMOUNT/100000000,0);
SV:=IF(KB2>KS2,AMOUNT/100000000,0);
資金差:SUM(BV,0)-SUM(SV,0);
N:=MIN(BARPOS,5);
資金差2:SUM(BV,N)-SUM(SV,N);

2.再建指標

A)
{疊加大盤}
POLYLINE(C,C),LINETHICK2,COLORBLACK;{要股價粗線刪除這句}
TC:=STRCMP(STRLEFT(MARKETLABEL,2),'SZ');
DPSH:="SH000001$CLOSE"/HHV(STKINDI('SH000001','大盤引用.昨收#DAY'),0);
DPSZ:="399001$CLOSE"/HHV(STKINDI('399001','大盤引用.昨收#DAY'),0);
DPC:=IF(INBLOCK('A股板塊'),DYNAINFO(3)*IF(TC=0,DPSZ,DPSH),C);
POLYLINE(C>0,DPC),COLORMAGENTA,LAYER0;
C,COLORWHITE,LAYER0;

B)
{大盤力度}
總:STKINDI('SH000001','大盤引用.資金差#TICK');
五分:STKINDI('SH000001','大盤引用.資金差2#MIN1'),LINETHICK0;
STICKLINE(五分>0,五分,0,1,0),Color5050FF;
STICKLINE(五分<=0,五分,0,1,0),ColorFFFF00;

?

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

?

 

有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

怎么收費,代編流程等詳情請點擊查閱!

(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  浙江体彩6+1规则