您現在的位置:程序化交易>> 股票公式>> 通達信>> 通達信公式>>正文內容

支撐壓力主圖指標公式(主圖指標公式、公式、源碼、使用說明、)[通達信公式]

相關標簽:

?

?

原理解析:


?

?來源:程序化99( www.qvudci.tw )

源碼:

?

?

?

MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
MA20:MA(CLOSE,20);
MA60:MA(CLOSE,60)COLORRED;
MA120:MA(CLOSE,120),COLORFF972F;
金叉:=CROSS(MA5,MA10);
DRAWTEXT(金叉,MA10*0.99,'←金叉買'),COLORYELLOW;
二金叉:=CROSS(MA10,MA20);
DRAWTEXT(二金叉,MA20*0.98,'←二金叉加倉'),COLOR1880FF;
{無窮}
無窮:DMA(CLOSE,(VOL)/(CAPITAL));
XG:=CROSS(C,無窮) AND V>REF(V,1)*1.618;
STICKLINE(C/REF(C,1)>1.095,C,O,2,0),COLORMAGENTA;
STICKLINE(C/REF(C,1)<0.95,C,O,2,0),COLORGREEN;
{支撐壓力}
N:=(H+L+C)/3;
明1壓:2*N-L,LINETHICK0,NODRAW;
STICKLINE(ISLASTBAR,(明1壓),(明1壓),100,0),COLORCYAN,;
DRAWTEXT(ISLASTBAR,明1壓,'明1壓 ');
明1支:2*N-H,LINETHICK0,NODRAW;
STICKLINE(ISLASTBAR,(明1支),(明1支),100,0),COLORCYAN,;
DRAWTEXT(ISLASTBAR,明1支,'明1支 ');明2壓:N+H-L,LINETHICK0,NODRAW;
STICKLINE(ISLASTBAR,(明2壓),(明2壓),100,0),COLORCYAN,;
DRAWTEXT(ISLASTBAR,明2壓,'明2壓 ');
明2支:N-H+L,LINETHICK0,NODRAW;
STICKLINE(ISLASTBAR,(明2支),(明2支),100,0),COLORCYAN,;
DRAWTEXT(ISLASTBAR,明2支,'明2支 ');
{乖離}
BIAS1:=(C-MA(C,6))/MA(C,6)*100;
BIAS2:=(C-MA(C,12))/MA(C,12)*100;
BIAS3:=(C-MA(C,24))/MA(C,24)*100;
BIAS:=(BIAS1+2*BIAS2+3*BIAS3)/6;
乖離:=MA(BIAS,3);
DRAWTEXT(CROSS(BIAS,乖離) AND 乖離<-9.5,L*0.95,'↖紅柱抄底'),COLORRED;
{KD}
K:=(C+H+L)/3; D:=MA(K,4);
DRAWTEXT(REF(C,1)>D AND C<D AND D>REF(D,1),H*1.02,'←賣'),COLORYELLOW;
DRAWTEXT(REF(C,1)<D AND C>D AND D<REF(D,1) AND C>REF(C,1)*1.045,L*0.98, '←買'),COLORMAGENTA;

?

?


用法說明:

  1.支撐線和壓力線的作用

  支撐線又稱為抵抗線。當股價跌到某個價位附近時,股價停止下跌,甚至有可能還有回升。這個起著阻止股價繼續下跌或暫時阻止股價繼續下跌的價格就是支撐線所在的位置。

  壓力線又稱為阻力線。當股價上漲到某價位附近時,股價會停止上漲,甚至回落。這個起著阻止或暫時阻止股價繼續上升的價位就是壓力線所在的位置。

  支撐線和壓力線的作用是阻止或暫時阻止股價向一個方向繼續運動。同時,支撐線和壓力線又有徹底阻止股價按原方向變動的可能。

  2.支撐線與壓力線相互轉化

  一條支撐線如果被跌破,那么這個支撐線將成為壓力線;同理,一條壓力線被突破,這個壓力線將成為支撐線。這說明支撐線和壓力線的地位不是一成不變的,而是可以改變的,條件是它被有效的足夠強大的股價變動突破。

  3.支撐線和壓力線的確認和印正

  一般來說,一條支撐線或壓力線對當前影響的重要性有三個方面的考慮,一是股價在這個區域停留時間的長短;二是股價在這個區域伴隨的成交量大??;三是這個支撐區域或壓力區域發生的時間距離當前這個時期的遠近。

?

公式導入教程: 【通達信公式源碼導入方法教程】 【同花順公式源碼導入方法教程】 【大智慧新一代公式源碼導入方法教程

?

 

有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流或微信:cxhjy888 進行 有償收費 編寫!(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

怎么收費,代編流程等詳情請點擊查閱!

(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)

 


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
  浙江体彩6+1规则