您現在的位置:程序化交易>> 期貨公式>> 博易大師>> 博易大師知識>>正文內容

麻煩老師幫忙改成博易大師模式,非常感謝! [博易POBO]

咨詢內容:

麻煩老師幫忙改成博易大師模式,非常感謝!

N:=10;
F:=26;
VAR1:=HHV(HIGH,9)-LLV(LOW,9);
VAR2:=HHV(HIGH,9)-CLOSE;
VAR3:=CLOSE-LLV(LOW,9);
VAR4:=VAR2/VAR1*100-70;
VAR5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR6:=(HIGH+LOW+OPEN+CLOSE)/4;
VAR7:=SMA(VAR3/VAR1*100,3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
VARA:=IF(VAR9>100,VAR9-100,0);
VARB:=HHV(HIGH,34);
VARC:EMA((VAR6-VAR8)/(VARB-VAR8)*100,13),NODRAW;
VARD:EMA(0.667*REF(VARC,1)+0.333*VARC,2),NODRAW;
SS:VARC-VARD,NODRAW;
//INDEXH:="999001$H";?
//INDEXL:="999001$L";
INDEXC:="999001$C";?
VARE:=SMA(MAX(CLOSE-REF(CLOSE,1),0)/CLOSE,8,1)/SMA(ABS(INDEXC-REF(INDEXC,1))/INDEXC,8,1)*100-25;
VARF:=MA(VARE,3);
VAR10:=REF(VARF,1);
生命線:EMA(VARD,N), COLORFFAA00;
VAR11:=(CLOSE-LLV(LOW,F))/(HHV(HIGH,F)-LLV(LOW,F))*100;
K:=SMA(VAR11,12,1);
D:=SMA(K,6,1);
//STICKLINE1(CROSS(VARC,VARD) AND VARC>VARD AND VARC<18,36,0,1,0), COLORRED;
見紅:=IF(VARC>18,0,IF(CROSS(VARC,VARD) AND VARC>VARD AND VARC<18,37,0)),COLOR3355FF;//{燈塔脈沖}
POLYLINE(CROSS(VARC,VARD) AND VARC>VARD AND VARC<18,25,COLORFF0000);
//{畫紅色燈樁}
POLYLINE(CROSS(VARC,VARD) AND VARC>VARD AND VARC<18,38,COLORFF0000),POINTDOT,LINETHICK7;
//{畫淺藍色燈輝}
POLYLINE(CROSS(VARC,VARD) AND VARC>VARD AND VARC<18,38,COLORFFFFFF),POINTDOT,LINETHICK4;
//{畫白色燈芯}
//STICKLINE1(CROSS(VARD,VARC) AND VARC<VARD AND VARC>60,90,100,12,1),COLORBLUE;
IF(VARC<79,100,IF(CROSS(VARD,VARC) AND VARD>79 AND VARC>79,70,100)),COLOR00FF00;
//{燈塔脈沖}
//STICKLINE1(FILTER(CROSS(VARD,VARC),10) AND VARD>79 AND VARC>79,100,95,4,0),COLORGREEN;
//{畫綠色倒燈樁}
STICKLINE1(VARC-VARD>0||K>D,VARC,VARD,8,1),COLOR0000FF;
//{多頭行情顯出紅柱狀}
STICKLINE1(VARC-VARD<0||K<D,VARC,VARD,8,0),COLOR00FF00;
//{空頭行情顯出綠色柱狀}
KAR1:=3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
KAR2:=(CLOSE-LLV(LOW,26))/(HHV(HIGH,26)-LLV(LOW,26))*100;
KAR3:=SMA(SMA(KAR2,3,1),3,1);
KAR4:=EMA(KAR3,5);
KAR5:=LLV(LOW,26);
KAR6:=HHV(HIGH,34);
KAR7:=EMA((CLOSE-KAR5)/(KAR6-KAR5)*4,4)*25;
KAR8:=100-KAR1;
KAR9:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
KAR10:=SMA(KAR9,3,1);
KAR11:=SMA(KAR10,3,1);
KAR12:=EMA(3*KAR10-2*KAR11,3);
KAR13:=(-1)*(EMA(KAR8,1)-50)+50;
KAR14:=EMA(100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14)),6);
//STICKLINE1(CROSS(KAR4,10) AND KAR4>10,50,0,10,0),COLORYELLOW;
建倉:=IF((KAR7<10),18,0), COLORCC00FF;

?

?來源:程序化99網( www.qvudci.tw )

博易技術人員: N:=10;
F:=26;
VAR1:=HHV(HIGH,9)-LLV(LOW,9);
VAR2:=HHV(HIGH,9)-CLOSE;
VAR3:=CLOSE-LLV(LOW,9);
VAR4:=VAR2/VAR1*100-70;
VAR5:=(CLOSE-LLV(LOW,60))/(HHV(HIGH,60)-LLV(LOW,60))*100;
VAR6:=(HIGH+LOW+OPEN+CLOSE)/4;
VAR7:=SMA(VAR3/VAR1*100,3,1);
VAR8:=LLV(LOW,34);
VAR9:=SMA(VAR7,3,1)-SMA(VAR4,9,1);
VARA:=IF(VAR9>100,VAR9-100,0);
VARB:=HHV(HIGH,34);
VARC:EMA((VAR6-VAR8)/(VARB-VAR8)*100,13),NODRAW;
VARD:EMA(0.667*REF(VARC,1)+0.333*VARC,2),NODRAW;
SS:VARC-VARD,NODRAW;
//INDEXH:="999001$H";?
//INDEXL:="999001$L";
//INDEXC:="999001$C";?
VARE:=SMA(MAX(CLOSE-REF(CLOSE,1),0)/CLOSE,8,1)/SMA(ABS(INDEXC-REF(INDEXC,1))/INDEXC,8,1)*100-25;
VARF:=MA(VARE,3);
VAR10:=REF(VARF,1);
生命線:EMA(VARD,N), COLORFFAA00;
VAR11:=(CLOSE-LLV(LOW,F))/(HHV(HIGH,F)-LLV(LOW,F))*100;
K:=SMA(VAR11,12,1);
D:=SMA(K,6,1);
//STICKLINE1(CROSS(VARC,VARD) AND VARC>VARD AND VARC<18,36,0,1,0), COLORRED;
見紅:=IF(VARC>18,0,IF(CROSS(VARC,VARD) AND VARC>VARD AND VARC<18,37,0)),COLOR3355FF;//{燈塔脈沖}
POLYLINE(CROSS(VARC,VARD) AND VARC>VARD AND VARC<18,25),COLORFF0000;
//{畫紅色燈樁}
POLYLINE(CROSS(VARC,VARD) AND VARC>VARD AND VARC<18,38),COLORFF0000,POINTDOT,LINETHICK7;
//{畫淺藍色燈輝}
POLYLINE(CROSS(VARC,VARD) AND VARC>VARD AND VARC<18,38),COLORFFFFFF,POINTDOT,LINETHICK4;
//{畫白色燈芯}
//STICKLINE1(CROSS(VARD,VARC) AND VARC<VARD AND VARC>60,90,100,12,1),COLORBLUE;
IF(VARC<79,100,IF(CROSS(VARD,VARC) AND VARD>79 AND VARC>79,70,100)),COLOR00FF00;
//{燈塔脈沖}
//STICKLINE1(FILTER(CROSS(VARD,VARC),10) AND VARD>79 AND VARC>79,100,95,4,0),COLORGREEN;
//{畫綠色倒燈樁}
STICKLINE(VARC-VARD>0||K>D,VARC,VARD,8,1),COLOR0000FF;
//{多頭行情顯出紅柱狀}
STICKLINE(VARC-VARD<0||K<D,VARC,VARD,8,0),COLOR00FF00;
//{空頭行情顯出綠色柱狀}
KAR1:=3*SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1)-2*SMA(SMA((CLOSE-LLV(LOW,75))/(HHV(HIGH,75)-LLV(LOW,75))*100,20,1),15,1);
KAR2:=(CLOSE-LLV(LOW,26))/(HHV(HIGH,26)-LLV(LOW,26))*100;
KAR3:=SMA(SMA(KAR2,3,1),3,1);
KAR4:=EMA(KAR3,5);
KAR5:=LLV(LOW,26);
KAR6:=HHV(HIGH,34);
KAR7:=EMA((CLOSE-KAR5)/(KAR6-KAR5)*4,4)*25;
KAR8:=100-KAR1;
KAR9:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
KAR10:=SMA(KAR9,3,1);
KAR11:=SMA(KAR10,3,1);
KAR12:=EMA(3*KAR10-2*KAR11,3);
KAR13:=(-1)*(EMA(KAR8,1)-50)+50;
KAR14:=EMA(100*(HHV(HIGH,14)-CLOSE)/(HHV(HIGH,14)-LLV(LOW,14)),6);
//STICKLINE1(CROSS(KAR4,10) AND KAR4>10,50,0,10,0),COLORYELLOW;
建倉:=IF((KAR7<10),18,0), COLORCC00FF; 來源 程序化久久網

 

有思路,想編寫各種指標公式,交易模型,選股公式,還原公式的朋友

可聯系技術人員 QQ: 262069696  點擊在線交流或微信號:cxh99cxh99  進行 有償收費 編寫!

怎么收費,代編流程等詳情請點擊閱讀!

(注:由于人數限制,QQ或微信請選擇方便的一個聯系我們就行,加好友時請簡單備注下您的需求,否則無法通過。謝謝您!)


【字體: 】【打印文章】【查看評論

相關文章

    沒有相關內容
浙江体彩6+1规则